NavVis LXシリーズ(以下、NavVis デバイス)を用いたスキャン中に、手元のプレビュー画面(モニタ)上で「NavVis デバイスの現在位置がリアルタイムに更新されない」「数秒~十数秒遅れて更新される」といった問題が生じることがあります。この現象を NavVis社では 「SLAM ラギング」と呼んでいます。
SLAM ラギングの原因は幾つかありますが、「繰り返し、屋内外問わず、どんな場所でも発生してしまう」場合は「記録メディアの書き込み遅延」に起因する可能性が高いです。また、SLAM ラギングが頻発している場合は、正しくデータセットを保存できないケースも発生し得ますので、できるだけ速やかに対策を講じてください。
原因
NavVis デバイスの記録メディアには、 NAND 型のフラッシュメモリー (VLXはSSD, MLXはUSB) が使用されています。この型式のフラッシュメモリーは一般に、データの書き込み・保存回数が増えると、性能が劣化する特性があります。劣化が進むと、記録時にエラーが発生します。具体的には、記録時に劣化箇所が見つかると、劣化していない場所へ再書き込みする処理が行われますが、この再書き込みが繰り返し生じることで、書き込みに遅延が生じ、最悪の場合は書き込みが失敗してしまいます。SLAMラギングはその影響の一つです。
1つのデータセット(1回のスキャニング)で記録されるファイル数は、多い時には1万ファイルを超える場合もあります。NavVis デバイスの記録メディアに対しては、PCなどに搭載されている SSD と比較して、より多くの書き込みが行われます。もちろん、利用頻度にも依りますが、大量のデータ書き込みを繰り返し行っているため、PC の利用以上にご注意いただく必要がございます。
対策
日常のメンテナンスの一貫として次の対策をすることで、SLAM ラギングを回避することができます。
方法①:記録メディアのフォーマット
「NavVis デバイスの記録メディアとフォーマット方法」を参考に記録メディアの初期化・フォーマットを行うことで改善させることができます。フォーマットにより記録済みデータは消去されます(バックアップは忘れずに!)。ただし、その分、正常に記録できる領域を確保することができます。
スキャンプロジェクト実施前に毎回フォーマットしておくことは SLAM ラギング問題に対して非常に有効な手段です。
方法②:新しい記録メディアと交換する
記録メディア上で劣化した場所を復旧することはできません。フォーマットをしても 、「SLAM ラギングが発生してしまう」「スキャン終了時のデータセット保存時間が異常に長い」、あるいは「PC に記録メディアを接続した際、エラーが毎回検出される」といったことがある場合は新品と交換することを推奨いたします。
当社から防水キャップ付き SSD をご購入いただくことが可能です。
ご入用の場合は、弊社構造計画研究所もしくは販売店のNavVis営業担当までお知らせください。
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